Guides & TutorialsTroubleshootingTroubleshooting Order Form IssuesCross-selling Recommendations Do Not Display on Order Form

Cross-selling Recommendations Do Not Display on Order Form

Symptom

You have configured cross-selling for a product, but the cross-sells (recommendations) do not appear on the order form page (cart.php) during the order process.

Cause

All of the products that you selected in the Cross-sells tab at Configuration > System Settings > Products/Services are hidden. Because there are no products to display, the cross-selling recommendation section does not display in the shopping cart.

Solution

To resolve this issue, you can either update the list of cross-sells for the product or disable hiding for the already-selected products.

Update the List of Cross-sells

To update the list of cross-sells for the affected product, use the Cross-sells tab at Configuration > System Settings > Products/Services.

Edit the Cross-sell Products

To ensure that the already-configured cross-sells can display in the recommendations section, edit those products to disable the Hidden option.

To do this:

  1. Go to Configuration > System Settings > Products/Services.
  2. Click Edit next to the product that should display as a cross-selling recommendation.
  3. Uncheck Hidden.
  4. Click Save Changes.
Uncheck the Hidden checkbox