Troubleshooting a Logon failure: unknown user name or bad password Error

Admins may encounter the following error when configuring support department mail importing via POP3 or as a notification email:

Logon failure: unknown user name or bad password

Cause

Usually, this error is due to one of the following causes:

  • An invalid username or password in the support department mail importing configuration.
  • Using an authentication method that your POP mailbox does not support.

If you receive a message about less secure apps, modern authentication, or OAuth from Google® or Microsoft®, see the Unsupported Authentication Method section below.

Solutions

Invalid Username or Password

To resolve this issue, ensure that WHMCS has the current login credentials for your mailbox:

  1. Click Edit at Configuration > System Settings > Support Departments.
  2. Update Email Address and Email Pass in the Mail Importing Configuration section.
  3. Click Save Changes.

With valid login credentials, the system can access the mailbox and import emails into the support ticket system.

Unsupported Authentication Method

Some email providers are phasing out the use of password for authentication to their email services, notably Google and Microsoft.

Google Email Users

To resolve this issue as a Google user, see Setting Up POP3 Importing with OAuth via Google.

Microsoft Email Users

If you are a Microsoft user (for example, Microsoft 365 and Exchange Online), Microsoft has announced that you can continue to use basic password authentication for POP3 and IMAP until January 2023.


Beginning 1st October 2022, Microsoft will randomly disable basic password authentication for their customers in preparation for the January 2023 deadline.


To continue using basic password authentication to import emails from Microsoft to WHMCS, see Microsoft's one-time re-enablement instructions.


If you cannot use basic password authentication for POP3 with your Microsoft Exchange service, you can forward emails to a regular mailbox that supports username-and-password authentication for POP3 and then import it via WHMCS.

To update the POP or IMAP import mailbox settings in WHMCS:

  1. Click Edit at Configuration > System Settings > Support Departments.
  2. Update Email Address and Email Pass in the Mail Importing Configuration section.
  3. Click Save Changes.

WHMCS v8.6 adds support for Microsoft's modern authentication methods. For more information, see Setting Up Importing via Microsoft.

Other Email Users

If you are unable to use basic password authentication for POP3 with your email provider, you can forward emails to a regular mailbox that supports username-and-password authentication for POP3 and then import it via WHMCS.

To update the POP or IMAP import mailbox settings in WHMCS:

  1. Click Edit at to Configuration > System Settings > Support Departments.
  2. Update Email Address and Email Pass in the Mail Importing Configuration section.
  3. Click Save Changes.

With valid login credentials, the system can access the mailbox and import emails into the support ticket system.