Troubleshooting a The file /path/to/whmcs/index.php is corrupted. Error
Symptom
When installing, upgrading or using WHMCS, you encounter the following error, where /path/to/whmcs/
is the location of your WHMCS installation, and index.php
is a filename:
The file /path/to/whmcs/index.php is corrupted.
Cause
This message has two possible causes:
1. The server environment does not include the required minimum version of ionCube Loader® and does not meet WHMCS's system requirements.
2. The file is unreadable because something modified it.
The majority of the system's PHP files are encoded using ionCube Encoder®, which compiles the software's source code and protects it from direct modifications. If something does edit these files, your server cannot decode them into the original PHP code and they become corrupt.
Solutions
ionCube Loader Minimum Requirement
Update ionCube Loader to the minimum required version. You may need to contact your system administrator or hosting provider to make this configuration change.
To do this on a cPanel & WHM server:
- Log in to WHM and go to Home >> Software >> EasyApache4.
- Click Customize for the current configuration.
- Select PHP Extensions.
- Use the Search filter to locate the ionCube settings.
- Toggle the appropriate ionCube loaders option to the on position for your PHP version.
- Review and provision the new configuration.
- Return to WHMCS and refresh the page.
If the issue persists, see File Corruption below.
If you are changing the PHP version, see the PHP Upgrade Guide.
File Corruption
If your ionCube Loader version meets the system requirements, a file may be corrupt.
To fix this issue and replace the modified file with the original copy:
- Download a new copy of the WHMCS Full Release files from http://download.whmcs.com or your license reseller.
- Upload the Full Release
.zip
file to your server. - Extract the WHMCS files, ensuring that they all overwrite successfully.
- Return to WHMCS and refresh the page.
If the problem occurs again, compare the corrupted file on your server to the file from http://download.whmcs.com. Look for any differences between the files. Then, contact your system administrator or hosting provider to investigate why the files changed after upload.