Troubleshooting Problems Accepting EULA After Update
Symptom
After applying the WHMCS 7.6 update, upon first logging to the administration area, it is necessary to read and agree to an updated License Agreement (EULA).
In some circumstances, clicking the Accept button may reload the page or result in a 404 error:
The requested URL /admin/eula-accept was not found on this server.
Click to copy
Cause
This is caused by a mis-configured Friendly URLs setting, causing the Accept button to point to an unroutable path on your server.
Solution
The Friendly URL setting can be reset to the basic value by executing the following SQL command against the WHMCS database:
UPDATE `tblconfiguration` SET value ='basic' WHERE setting='RouteUriPathMode';
Click to copy
Refresh the License Agreement page in your browser.
The updated Agreement can now be accepted successfully