Troubleshooting Empty Page Contents
Symptom
When visiting specific pages in a WHMCS installation, the page content appears to be missing.
The following screenshots show the shopping cart and registration pages exhibiting the issue:
Cause
The template file for the page is missing or contains a syntax error.
Diagnosis
To diagnose this:
1. Log in to the WHMCS Admin Area.
2. Go to Configuration > System Logs.
![Configuration > System Log](https://media.screensteps.com/image_assets/assets/005/237/907/original/184c6c12-c5ba-4a7b-91dc-9044b3cef761.png)
3. Review the System Activity Log for Smarty Error
entries. The error message provides details about the cause, including the filename of the problematic template file:
![System Activity Log](https://media.screensteps.com/image_assets/assets/005/237/909/original/cb292f62-49c7-4dd0-ae83-2d0dbf8779e7.png)
Resolution
The first message indicates that the /templates/twenty-one/clientregister.tpl
file is missing:
Smarty Error: Default handler: No template default content for 'file:twenty-one/clientregister.tpl'
To resolve this error, restore or upload the missing file that the Smarty Error identified.
The second message indicates invalid code in the /templates/orderforms/standard_cart/configureproduct.tpl
file around line 5:
Smarty Error: Syntax error in template "file:/home/v84whmcssupport/public_html/whmcs/templates/orderforms/standard_cart/configureproduct.tpl" on line 5 "'addToCart': '{$LANG.orderForm.addToCart|escape}'," - Unexpected " "
To resolve the error, open the file and examine the code syntax around the line number. Correct the syntax error and save the file.
In this example, a duplicated {
character causes the syntax error:
![configureproduct.tpl - cPanel File Manager v3 — Mozilla Firefox](https://media.screensteps.com/image_assets/assets/005/237/911/original/c46cbd4e-ea26-4f4f-aa26-e4a7503e8fe1.png)