Cron stuck on Executing System Queue step
Symptom
During the daily automation cron run, the script takes a long time to complete. The troubleshooting steps in Advanced Cron Troubleshooting indicate that Executing System Queue is responsible for most of the used time.

Cause
The PHP process to generate and zip the backup of the WHMCS database can take a long time to process large MySQL® databases or data on resource-restricted servers.
The backup process will require a large amount of time to complete as your WHMCS database increases in size.
Solution
To resolve this issue:
- Perform the available System Cleanup tasks to help reduce cruft from the WHMCS database.
- Disable FTP/SFTP Backup and Email Backup. To do this:
- Navigate to Configuration > System Settings > Database Backups.
- Select FTP/SFTP Backups.
- Click Deactivate.
- Select Daily Email Backups.
- Click Deactivate.
If you have installed WHMCS on a cPanel & WHM server, we recommend configuring cPanel backups instead.