Connection unsuccessful. Please close this window and try again with Microsoft
Symptom
When configuring Microsoft® as your mail provider or for email importing, a Connection unsuccessful
error message displays after you click Connect:
Connection unsuccessful. Please close this window and try again.
Cause
The Application (client) ID and Client Secret combination for your Microsoft Azure® app are invalid.
Resolution
Create a new app via the Microsoft Azure Portal. Make certain to copy the Application (client) ID and Client Secret Value correctly.
The Application (client) ID is displayed on the App's home screen:
The Client Secret Value is displayed on the App's Certificates & secrets screen after creating the secret:
For step-by-step instructions, see: