Connection unsuccessful. Please close this window and try again with Microsoft
Symptom
When configuring Microsoft® as your mail provider or for email importing, a Connection unsuccessful
error message displays after you click Connect:
Connection unsuccessful. Please close this window and try again.

Cause
The Application (client) ID and Client Secret combination for your Microsoft Azure® app are invalid.
Resolution
Create a new app via the Microsoft Azure Portal. Make certain to copy the Application (client) ID and Client Secret Value correctly.
For step-by-step instructions, see: