Guides & TutorialsTroubleshootingTroubleshooting Payments and CurrenciesTroubleshooting Chrome Browser Crashes with 2CheckOut Inline Checkout

Troubleshooting Chrome Browser Crashes with 2CheckOut Inline Checkout

Symptom

Chrome™ browsers may crash when your customer makes a payment using 2Checkout.

Aw, Snap! RESULT_CODE_KILLED_BAD_MESSAGE

Cause

Your Checkout Style setting in the 2CheckOut module configuration is Inline Checkout.

2Checkout has deprecated the inline checkout style and no longer supports it.

Workaround

To work around this temporarily, ask clients to attempt payment again using a different browser (for example, Firefox®, Opera, or Safari®).

Solution

To resolve this issue:

  1. Go to Configuration > System Settings > Payment Gateways.
  2. Change Checkout Style from Inline Checkout to Standard Checkout.
  3. Click Save Changes.
Payment Gateways Settings showing Standard Checkout Style

For more information, see 2Checkout.