Guides & TutorialsSupport Tools TroubleshootingTroubleshooting an Argument 7 passed to processPoppedTicket() Error

Troubleshooting an Argument 7 passed to processPoppedTicket() Error

Symptom

After performing a WHMCS software update, emails that the system imported to the support ticket system bounce back to the sender with the following error: Argument 7 passed to processPoppedTicket()

Argument 7 passed to processPoppedTicket() must be an instance of WHMCS\Mail\AutoSubmittedHeader, array given, called in /path/to/crons/pop.php on line 0

Cause

This issue is due to the presense of a pop.php file from an older version of WHMCS.

This occurs if you have customised the location of the crons directory and:

1. The $crons_dir  value is missing from the configuration.php file. As a result, the crons folder wasn't updated by the automatic updater as WHMCS  was unaware of the custom location.

2. During a manual update, the new crons directory contents did not copy to the custom location.

Solution

To resolve this issue:

1. Download the full release files from httpos://download.whmcs.com (or contact your license reseller).

2. Upload a new set of files from the crons directory to the custom location on your server, overwriting the existing files. This should resolve the error.

3. Review the Custom Crons Directory documentation to ensure all the necessary steps have been completed.