Shopping Cart Promotions Do Not Display

Symptom

MarketConnect service promotions do not automatically display during the order process for applicable services.

Cause

The two most common causes of this issue are that you have disabled MarketConnect promotions or that the MarketConnect addons are not correctly associated with your products.

Solutions

Enable Promotions

To enable MarketConnect promotions:

  1. Go to Configuration > System Settings > MarketConnect or, prior to WHMCS 8.0, Setup > MarketConnect.
  2. Select the desired MarketConnect service.
  3. In the Promotion Settings tab, set the settings under Shopping Cart to On.

Assign Addons to Products

MarketConnect automatically assigns addons to all of your applicable products based on their product types.

If you are experiencing issues, check whether the addon's applicable products are correctly configured:

  1. Go to Configuration > System Settings > Product Addons or, prior to WHMCS 8.0, Setup > Products & Services > Product Addons.
  2. Click the edit icon for the desired MarketConnect addon.
  3. In the Applicable Products tab, check to ensure that all of the desired products appear under Selected Products.