Guides & TutorialsTroubleshootingAdvancedTroubleshooting an Order Not Found...Exiting... Error

Troubleshooting an Order Not Found...Exiting... Error

The error message Order not found.. Exiting... may be encountered when placing a new order.  This is likely to be experienced in conjunction with a number of other errors.

This guide shows how to identify the cause of this error and provides the solution.

Symptoms

When placing an order, you encounter an error message like this:

Cause

This error is caused by an inability for the WHMCS software to write to the MySQL database. This is typically due to the MySQL server being in strict mode. To confirm whether this is the case, a tool such as phpmyadmin can be used.

From the phpmyadmin homepage, click the Variables tab:

Scroll down to find the sql mode variable:

Make a note of the sql mode value.

If the value contains both or either of the following settings, then MySQL Strict Mode is enabled:

STRICT_TRANS_TABLES,STRICT_ALL_TABLES
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Solution

To resolve this problem, please adjust your MySQL server configuration so as to disable Strict Mode.

This can usually be done by configuring the mysqld service, or editing the /usr/my.cnf file (depending upon your server configuration).
We recommend the following value:

NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
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It may be necessary to contact your server admin/hosting provider to make this server configuration change.

Please also take this opportunity to ensure your server meets all the System Requirements and resolve any errors on the Help > System Health Status page inside the WHMCS Admin area