Guides & TutorialsTroubleshootingCommon ErrorsTroubleshoot Duo Security Login Failures

Troubleshoot Duo Security Login Failures

Problem

You or your clients see errors or experience other problems while attempting to use Duo® Security for two-factor authentication (2FA).

For example, you may see the following error in the Activity Log at Configuration > System Logs:

Client Duo Security Login Failed: invalid_client: Integration type does not support frameless access.

Cause

Duo ended support for the previous Duo Security iframe-based prompt on March 30, 2024. This error indicates that you need to upgrade your Duo credentials.

Solution

We updated our Duo Security integration in WHMCS 8.9 and later to use Duos newer Duo Universal Prompt. To resolve Duo Security errors, you must ensure that your system is running WHMCS 8.9 or higher and activate Universal Prompt in your Duo Security account.

To resolve this error:

  1. Make certain that you have successfully updated to WHMCS 8.9 or later.
  2. Make at least one login attempt that uses Duo Security for 2FA.
  3. Log in to your Duo Security account.
  4. Click Applications in the left-side menu.
  5. Click on the application that you use with WHMCS.
  6. Find the Universal Prompt section.If you have not yet updated WHMCS or made at least one login attempt with Duo Security, you will see an Update required message. Make certain that you have successfully performed these steps.If your account is ready to activate Universal Prompt, you will see a Ready to activate message and a green checkmark icon next to Application Supports Universal Prompt.
  7. Under Activate Universal Prompt, select Show new Universal Prompt.
  8. Return to WHMCS and attempt authentication again.