Guides & TutorialsTroubleshootingLicensing TroubleshootingTroubleshooting Invalid License on HostGator Servers

Troubleshooting Invalid License on HostGator Servers

Symptom

HostGator customers may experience an Invalid License message displayed when accessing the WHMCS admin area:

WHMCS - Invalid License

You may also encounter storage related errors, such as an inability to attach files to client accounts or support tickets, and apply automatic updates within WHMCS.

Cause

We have observed HostGator making mass changes to the home directory in which account files are located.

This is presumed due to a server migration or configuration changes.

 

To confirm if this is the case, observe the Home Directory value within cPanel to see if it has changed from:

/home/username

to:

/home2/username

cPanel Home Directory

Solution

Updating the WHMCS software following a change in home directory paths is a 3 stage process.

Click each stage below to display the steps to perform:

 

1. Reissue the WHMCS License

Contact HostGator support to reissue your WHMCS license key: https://www.hostgator.com/help/article/whmcs-notice-your-license-is-no-good

Once the license has been reissued, access to the WHMCS admin area will immediately be restored.

 

2. Update Storage Settings

The Storage Settings must be updated so WHMCS knows where downloads and attachments are located:

1. Login to your WHMCS Admin Area

2. Navigate to Setup > Storage Settings

3. Click the Configurations tab

4. Click the Play icon button for each Storage Configuration

5. Observe for a green success or red error message:

Setup > Storage Settings

If you observe the following error message, then the storage settings require updating:

Configuration settings could not be verified. Directory must exist and be writable

 

1. In the Add New Configuration section, click the + icon

Add a new Storage Configuration

2. A modal will appear. Enter the new full path to your downloads directory:

Enter new directory path

Contact HostGator support if you are unsure of the full path to the downloads directory

3. Click Save Changes

4. If a valid and writable directory path entered, the modal will close and display a success message in the top-right corner of the screen:

Success!

5. In the Add New Configuration section, click the + icon again

Add a new Storage Configuration

6. A modal will appear. Enter the new full path to your attachments directory:

Enter new directory path

Contact HostGator support if you are unsure of the full path to the attachments directory

7. Click Save Changes

8. If a valid and writable directory path entered, the modal will close and display a success message in the top-right corner of the screen again.

The Storage Settings Configurations page should now look like this:          

New Storage Configurations Added

9. Click the Settings tab

10. Use the dropdown menus to select the new storage locations beginning /home2/:

  • Client Files
  • Downloads
  • Email Attachments
  • Email Tempalte Attachments
  • Ticket Attachments
  • Knowledgebase Images (WHMCS v7.10 and above only)
Switch Storage Settings

11. Click all the Migrate buttons where available. Otherwise click the Switch buttons

12. Once all migration and switching is complete. Your attachment and downloads will be accessible once more, and clients will be able to attach new files.

 

3. Update the Auto-Updater Settings

1. Navigate to Utilities > Update WHMCS

2. Click Configure Update Settings in the top-right corner:

Configure Update Settings Button

3. Adjust the Temporary Path setting in the modal window which appears:

WHMCS - Update WHMCS

Contact HostGator support if you are unsure of the full path to the downloads directory

4. Click Save Changes

 

Once all these steps have been completed, your WHMCS installation will be back to full operation again after the HostGator migration.