Guides & TutorialsTroubleshootingTroubleshooting Payments and CurrenciesTroubleshooting PayPal IPN Failure Emails in v8.0 and 8.1

Troubleshooting PayPal IPN Failure Emails in v8.0 and 8.1

Symptom

Whilst operating WHMCS version 8.0 or 8.1 and using the PayPal module, an automated notification email may be received from PayPal with information of IPN failures:

Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

https://www.example.com/whmcs/

If  you do not recognize this URL, you may be using a service provider that  is using IPN on your behalf. Please contact your service provider with  the above information. If this problem continues, IPNs may be disabled  for your account.

The URL listed is a directory name. This article does not apply if a full file path is listed

Cause

Payment notifications using an older PayPal Basic module are being sent for payments made via a newer PayPal module.

The newer PayPal module does not utilize IPNs, meaning these notifications are surplus to requirements. The URL reporting the failures must return a 200 HTTP response, which is not the case when used in conjunction with the Default to Client Area option.

Solution

Update to WHMCS 8.4.0 or above via the Utilities > Update WHMCS page.

CORE-17221 - Prevent redirection loop for invalid CSRF checks in client area

https://docs.whmcs.com/Changelog:WHMCS_V8.4.0_Beta_1#Maintenance

Workaround

1. Navigate to Configuration > System Settings > General Settings.

WHMCS - Manage Orders

2.  Select the Other tab.

3. Untick the Default to Client Area option.

WHMCS - General Settings

4. Click Save Changes.