Problems with one or more features following update
Symptoms
After applying an update, some WHMCS features may cease functioning, encounter an error, appear poorly formatted, or not display.
This may include features in the Client Area, shopping cart, or Admin Area.
Cause
In the majority of cases, this behavior is due to outdated customized template files.
If you have used template files to customize the appearance of WHMCS, you must update them for use with the latest version.
Solution
You can find the template changes between each version of WHMCS in the Release Notes. For example, see the template changes between WHMCS 8.8 and WHMCS 8.9.
Review all of the files in these lists against your custom template files in the templates/template_name
directory, where template_name
is your template's name.
For each change, remove the red - line and replace it with the green + line:
If you purchased your custom template from a third-party vendor, check the corresponding WHMCS Marketplace listing for available updates and then contact the vendor to obtain them.
After you have applied all of the template updates, clear the template cache:
1. Log in to the Admin Area.
2. Go to Utilities > System > System Cleanup.
3. Click Go under Empty Template Cache.