On-Demand Renewal Not Supported by Service
Symptom
After updating to WHMCS 8.8, some services on the Renew Service page display a Renewal Unavailable badge with a On-Demand Renewal Not Supported by Service message.
Cause
The service is not eligible for on-demand renewals.
Services are eligible for on-demand renewals if all of the following statements are true:
- The associated product supports on-demand renewals.
- The associated product uses the recurring payment type.
- The associated product does not use Metric Billing.
- The service's status is Active.
- There are no unpaid invoices for the service.
- The service's Next Due Date is within the renewal period limits.
Solution
To resolve this issue:
- Enable on-demand renewals for the system and the product.
- Confirm that the Payment Type value is Recurring in the product's Pricing tab.
- Confirm that you have set the Metric Billing options to OFF in the product's Module Settings tab.
- Confirm that the service's status is Active.
- Confirm that there are no unpaid invoices for the service.
- Confirm that the service's Next Due Date is within the renewal period limits.