Guides & Tutorials8.8 UpdateTroubleshootingOn-Demand Renewal Not Supported by Service

On-Demand Renewal Not Supported by Service

Symptom

After updating to WHMCS 8.8, some services on the Renew Service page display a Renewal Unavailable badge with a On-Demand Renewal Not Supported by Service message.

On-Demand Renewal Not Supported by Service

Cause

The service is not eligible for on-demand renewals. 

Services are eligible for on-demand renewals if all of the following statements are true:

  • The associated product supports on-demand renewals.
  • The associated product uses the recurring payment type.
  • The associated product does not use Metric Billing.
  • The service's status is Active.
  • There are no unpaid invoices for the service.
  • The service's Next Due Date is within the renewal period limits.

Solution

To resolve this issue:

  1. Enable on-demand renewals for the system and the product.
  2. Confirm that the Payment Type value is Recurring in the product's Pricing tab.
  3. Confirm that you have set the Metric Billing options to OFF in the product's Module Settings tab.
  4. Confirm that the service's status is Active.
  5. Confirm that there are no unpaid invoices for the service.
  6. Confirm that the service's Next Due Date is within the renewal period limits.