Email Importing invalid SASL argument Errors
Symptom
When you troubleshoot issues in which the system is not importing email from Google® email accounts after upgrading to WHMCS 8.6 and modifying the support department settings, you may see an invalid SASL argument
error:
last request failed: invalid SASL argument
The Mail Import test failed: Oauth2 auth failed, BAD Invalid SASL argument.
Cause
Some of the required information for POP3 email importing via the Google OAuth2 authentication method is missing.
Workaround
Execute the following MySQL® query against your WHMCS database. You can do this using the SQL tab in phpMyAdmin:
UPDATE tblticketdepartments SET login = '[email protected]' WHERE name = 'Name of Department';
- Replace
[email protected]
with the email address of the Google mailbox. - Replace
Name of Department
with the name of the support department.