Guides & Tutorials8.6 Update TroubleshootingHow to Use WHMCS with PHP 8.1

How to Use WHMCS with PHP 8.1

You must meet certain prerequisites and prepare your system before you can start using PHP 8.1 with WHMCS.

Prerequisites

You must meet the following prerequisites before you can use WHMCS with PHP 8.1:

  • You must upgrade to WHMCS 8.6 or higher.
  • You must be using ionCube Loader® 12.0.1 or higher.

For more information, see our System Requirements.

Prepare your system

For the best experience and minimized risk of disruption or downtime, we recommend performing the following steps in the following order:

  1. Upgrade ionCube Loader to version 12.0.1 or above.
  2. Upgrade to WHMCS 8.6 or above.
  3. In the WHMCS Admin Area, check for any incompatibilities using the utility at Utilities > System > PHP Version Compatibility.
  4. Check to ensure that the custom or third-party code you use is compatible with PHP 8.1.
  5. Upgrade to PHP 8.1.

For more information, see PHP Migration Guide and Updating to WHMCS 8.6 & PHP 8.1 blog.