Troubleshooting zero price products not adding to cart
Symptom
After applying the 8.2.0 update, you may observe that some products cannot be added to the shopping cart.
Cause
This behavior is observed in products with a recurring price of 0.00
.
Solution
Please apply the 8.2.1 Maintenance Release via the Utilities > Update WHMCS page.
Workaround
Adjust the product's recurring price to 0.01
or change the Payment Type option from Recurring to Free.
Hotfix
A hotfix has been created for 8.2.0 only to correct this behaviour:
https://whmcs.community/files/file/165-core-16844-add-zero-price-recurring-products-to-cart/