PayPal Subscription Cancellation Emails

Symptom

In v8.11, shortly after an invoice is paid, Clients and PayPal administrators receive an email from PayPal stating that Client's payment profile is cancelled. The subject of the email may be Profile cancelled.

The PayPal Subscriptions for a Client are cancelled and the Payment Methods settings on the Client Account's services and invoices switched from PayPal Basic/PayPal Checkout to PayPal Payments.

Cause

This is part of the Transition from Deprecated PayPal Modules and is a normal part of the process.

  • Payments via PayPal for this Client Account will now be processed via the PayPal Payments module without interruption.
  • No action is required by you or the Client.

Details

When an invoice in a Client Account is paid, the system evaluates the following criteria:

  1. The invoice was paid via one of PayPal Basic, PayPal Checkout or PayPal Payments payment gateways.
  2. The PayPal Payments payment gateway module is enabled in the system, plus either PayPal Basic or PayPal Checkout.
  3. The Client Account contains a service, domain or addon with a PayPal Subscription ID and the Payment Method is PayPal Basic or PayPal Checkout.
  4. The Client Account contains a PayPal Pay Method, which was created by paying an invoice via the PayPal Payments module.

If all the criteria are met, the system will cancel all PayPal Subscriptions in the Client Account and change the Payment Method of all services, domains and addons from PayPal Basic or PayPal Checkout to the PayPal Payments module.

All subsequent PayPal payments for the Client Account will be processed via the PayPal Payments module with charges made on-demand via the linked PayPal account contained in the Pay Method.

Only services, domains or addons using the PayPal Basic or PayPal Checkout will be updated. No changes will be made to other payment gateway modules.

Further Reading

To learn more about the benefits of the PayPal Payments payment gateway module, please see: