Guides & Tutorials8.10 UpdateWHMCS 8.10Cloudflare Proxy Check on System Health page after configuring Trusted Proxy settings

Cloudflare Proxy Check on System Health page after configuring Trusted Proxy settings

Symptom

After updating to WHMCS 8.10.1, a Cloudflare® Proxy Check notice is displayed in the Attention Items column of the Configuration > System Health page.

After the completing the steps to configure the Trusted Proxy Settings, the check is still shown in the Attention Items column:

Cloudflare Proxy Check Attention Item

Cause

Case CORE-19225 is opened with the development team to improve the logic of this System Health Check to be more informative on environments where the PHP REMOTE_ADDR superglobal variable is rewritten by the server.

Workaround

Confirm that visitor IP addresses are being correctly passed to the system by the webserver:

1. Go to Configuration > System Logs >  Admin Log

2. Review the IP Address column for your admin user.

IP Address

3. If the IP Address shows your internet connection's IP address correctly, then no further action is necessary. The Cloudflare Proxy Check health check and can be safely ignored.