Guides & Tutorials8.0 Update TroubleshootingTroubleshooting v8.0 not appearing after checking for updates

Troubleshooting v8.0 not appearing after checking for updates

Symptom

After navigating to Utilities > Update WHMCS  and clicking Check for Updates, no error is displayed, but the latest version remains at 7.10.x

WHMCS - Update WHMCS

If an error message is displayed, please refer to Updating WHMCS for configuration and troubleshooting advice.

Cause

The Automatic Update Utility performs an analysis of the current server environment and has determined that the system requirements are not met to run WHMCS v8.0.

Therefore the latest version compatible with your current server environment configuration is displayed.

The system requirements for WHMCS v8.0 require a PHP version of 7.2 or above.

Solution

Please contact your server admin/hosting provider for assistance updating the version of PHP in use to meet the system requirements for WHMCS v8.0.

Please also use this opportunity to ensure your server environment meets all the recommended requirements for running WHMCS: https://docs.whmcs.com/System_Requirements

Once the WHMCS v8.0 system requirements are met:

  1. Refresh the Utilities > Update WHMCS page
  2. Click the Check Now button
  3. The v8.0 update will now be available
  4. Click Update Now to start the update process

As always, before updating please take a few minutes to familiarise yourself with the Release Notes: https://docs.whmcs.com/Release_Notes