Troubleshooting Unexpected Overage Invoices

Symptom

After applying the 7.8.2 update at the end of the calendar month invoices for overage amounts may be generated for products where this type of billing was not intended.

Cause

This is caused by an update to facilitate overage billing where the soft  limit is 0, meaning you want to bill the customer for all usage.  Older  installations with product configurations not updated since WHMCS v5.1  may not have the necessary option flag to explicitly disable overage  billing.

Solution

A hotfix has been created which introduces logic to handle this scenario, preventing unexpected overage invoices in future. It can be downloaded from:

https://whmcs.community/files/file/113-core-13724-ensure-overage-billing-is-enabled-before-processing/