Guides & Tutorials7.7 Update TroubleshootingTroubleshooting Custom Invoice Numbers Not Applied

Troubleshooting Custom Invoice Numbers Not Applied

Symptom

After applying the 7.7.0 update, invoices generated by orders or the daily automation tasks do not receive the custom invoice number format specified in the new Tax Configuration interface.

Cause

Additional logic is required to ensure the appropriate invoice number format is applied.

Solution

A hotfix has been created which will resolve this error by including  additional logic to handle this scenario. It can be downloaded from:

https://whmcs.community/files/file/103-core-13106-pma-136-custom-invoice-numbering-and-invoice-time-entries/

Once the hotfix is applied subsequent invoices generated by WHMCS will have the appropriate custom invoice number format applied.

Follow-Up

Invoices generated without the custom number format, can be manually edited by viewing the invoice and clicking the Options tab.

Once all invoices have been updated, navigate to Setup > Payments > Tax Settings, and adjust the Next Invoice Number setting to the next invoice number which should be used.