Guides & Tutorials7.6 Update TroubleshootingTroubleshooting Slower Admin Area Performance After Update

Troubleshooting Slower Admin Area Performance After Update

Symptom

After applying the WHMCS 7.6 update, installations containing a large number of support tickets may experience longer loading times for every administration area page. The client area is not impacted.

Troubleshooting

Adding the following line to the configuration.php file to disable the support ticket counts in the admin header and footer instantly improves performance:

$disable_admin_ticket_page_counts = true;

Cause

Version 7.6 made changes to the way support ticket counts were calculated. This was less performant on installations with large volumes of support tickets.

Solution

A hotfix has been created which optimizes the calculation logic for improved performances on large installations. It can be downloaded from:

https://whmcs.community/files/file/93-core-12594-improve-ticket-count-queries-calculation/

Once the hotfix has been applied, admin area loading times will be immediately be reduced.