Guides & Tutorials7.6 Update TroubleshootingTroubleshooting Fraud Checks Not Being Performed

Troubleshooting Fraud Checks Not Being Performed

Symptoms

After applying the the WHMCS 7.6 update, you may encounter a situation whereby Maxmind fraud checks are not performed on new orders. All orders  automatically pass the fraud checks.

Upon review of the Utilities > Logs > Activity Log, the following entry is made at the time of the order:

MaxMind Fraud Check - Error Occurred: USER_ID_REQUIRED - A user ID and license key are required to use this service.

The Fraud Check Results section of the Order Details page also reflects this error:

A user ID and license key are required to use this service. (USER_ID_REQUIRED)

Cause

WHMCS Version 7.6 uses the newest version of the MaxMind minFraud API. This requires an additional credential set to function.

In version 7.5 and earlier, only the MaxMind License Key was required, now the MaxMind User ID is also required.

Solution

  1. Login to your MaxMind account at https://www.maxmind.com/en/account
  2. Click My License Key page in the left-hand navigation
  3. Note the Account/User ID value displayed on this page
  4. Login to your WHMCS administration area
  5. Navigate to Setup > Fraud Protection > Maxmind
  6. Enter your User ID into the MaxMind User ID field
  7. Click Save Changes
Enter MaxMind User ID

Fraud checks can now be performed on new orders. 

Follow-Up

To manually perform a fraud check on an existing order:

  • Navigate to Orders > List Add Orders
  • Click the Order ID in question
  • Click the Re-Run Fraud Check button
Re-Run Fraud Check button